2007年5月25日星期五

串連WIFLY與FON AP

四元(4$) 一直對小巧可愛的路由器非常感興趣,他寫了一篇關於 「Linux絕對有支援的無線網路卡」提到了ASUS WL-330gD-Link DWL-G730APBelkin Wireless G Travel Router 等非常省電容易攜帶的產品。

4$動了一個主意,想把可愛的La Fonera改裝成類似上述的產品,可以透過Ethernet 連上WiFi AP,再透過WiFi AP連上外部的網路。由於4$Hackathon的時,在cclien的協助下,成功的編譯了OpenWrt的開發版 Kamikaze,並燒進FON La Fonera中,因此他需要做的只是再把設定寫進去即可。

Hacking La fonera



很不幸的 4$ 改爛了設定檔,開了幾個 VLan,結果沒辦法透過無線或有線網路進入,把自己關在 AP 外面。因此週二帶了條傳輸線Tossug 聚會,幫忙進到 Console,並把相關的設定修正,以便讓他可以再 ssh 進 AP 裡。

FON hacking group

根據 OpenWrt Kamikaze 的設定方式,我們只消更改 /etc/config/network與/etc/config/wireless檔案,開兩個WiFi Interfaces,一個作為STA,另一個作為AP,並將Ethernet port與STA wireless interface "bridge" 在一起。

改後檔案像這樣
/etc/config/wireless
config wifi-device  wifi0
option type atheros
option channel 5
option diversity 0
option txantenna 1
option rxantenna 1
# option distance 2000
# disable radio to prevent an open ap after reflashing:
option disabled 0

config wifi-iface
option device wifi0
option network wan
option mode sta
option ssid "WIFLY"
option hidden 0
# option txpower 15
# option bgscan enable
option encryption none

config wifi-iface
option device wifi0
option network lan
option mode ap
option ssid "FON_AP"
option hidden 0
option encryption none

/etc/config/network

# Copyright (c) 2006 OpenWrt.org

config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface lan
option ifname eth0
option type bridge
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0
option gateway ''
option dns ''
option network ath0

config interface wan
option ifname ath1
option proto dhcp
如此一來,你就可以一邊連上WIFLY,另外一方面以FON_AP將WIFIY提供的網際網路連線分享給其他人用啦。:-)

接下來要做的是應該是改一條USB Cable,讓La Fonera可以直接吃USB的電源。;-)

Credits:
設備 - FON Taiwan
軟體開發 - cclian, 4$, jserv
攝影 - psilotum

Source: http://people.debian.org.tw/~chihchun/2007/05/25/leverage-wifly-and-fon/